Blog‎ > ‎

Adding H3Viewer to VS 2010 Menu

posted May 6, 2010, 3:45 AM by Robert Chandler   [ updated May 6, 2010, 5:32 PM ]
Thanks Jacques Lederer for these great tips on adding H3Viewer to the VS 2010 menu.

Hello there,

I think your H3Viewer is fantastic!
I also think the users will want to know how to integrate it in their VS 2010.
Here below is a procedure to do so.
Perhaps you could add this on your page.

Best regards,

Add the H3Viewer to the tools menu

  1. In VS 2010, go to Tools – External tools…
  2. Click on “Add” button. Type “H3Viewer” as Title,
    and navigate to the H3Viewer.exe for the “Command”. Click OK.
  3. Note the position of this "H3Viewer" in the external tools : In my case, it is the 3d external tool, there were already 2 installed : “Create GUID” and “Dotfuscator Software Services”. (Not mentioning the “&” which you can also use for shortcut with the Alt key).
  4. If you click on the Tools menu, you will see your "H3Viewer" in there. If you click on it, it should open H3Viewer. This is fine, but you want it in the “Help” menu…

The ultimate: have H3Viewer appear in the help Menu, like with previous versions of VS

  1. Right click on the menu bar, to the right of “Help”.
  2. Click on the Commands tab.
  3. In the Menu bar dropdown, select “Help”, at the very bottom of this dropdown.
  4. Click on the “Add Command” button.
  5. The “Add Command” dialog box opens up. In the left pane of it, select “Tools”
  6. In the right pane of it, select “External Command x” where x is the position of  the external tool added at step 1 (The H3Viewer). In my case I chose “External Command 3”
  7. Click “OK” and “Close”. Now you have your "H3Viewer" appearing in the "Help" menu as it should...

Note: Remember to set VS to local help mode, not online mode otherwise local help will not work. To do this open Help Library Manager (see VS 2010 help menu).
Comments